Cakephp 2.x User Management Premium Plugin Version 2.1

Upgrade Premium Version

If you have any confusion please let me know at chetanvarshney@gmail.com

1. Upgrade from 1.0 to 1.1

1. Run queries from yourapp/app/Plugin/Usermgmt/Config/Schema/sql-changes-1.1.txt
2. If you haven't changed 1.0 version files then you can replace 1.0 version with 1.1 version. See INSTALLATION guide from README file.
3. If you have your own changes in existing plugin. Then you should diff both versions with any Diff Softwares for e.g. Kdiff (http://kdiff3.sourceforge.net) Please take a backup of your existing files before overwriting.
4. I suggest you please do not overwrite new plugin to existing plugin instead of this you should make your changes in new plugin.
5. I have removed cake.generic.css from umstyle.css in 1.1 version, Now it's your wish you can use cake.generic.css separatly. If you want to use cake.generic.css then you should load it before plugin css.

2. Upgrade from 1.0 to 1.2 or 2.0

1. Run queries from yourapp/app/Plugin/Usermgmt/Config/Schema/sql-changes-1.1.txt
2. Run queries from yourapp/app/Plugin/Usermgmt/Config/Schema/sql-changes-1.2.txt
3. If you haven't changed 1.0 version files then you can replace 1.0 version with 1.2 or 2.0 version. See INSTALLATION guide from README file.
4. If you have your own changes in existing changes. Then you should diff both versions with any Diff Softwares for e.g. Kdiff (http://kdiff3.sourceforge.net) Please take a backup of your existing files before overwriting.
5. I suggest you please do not overwrite new plugin to existing plugin instead of this you should make your changes in new plugin.


3. Upgrade from 1.1 to 1.2 or 2.0

1. Run queries from yourapp/app/Plugin/Usermgmt/Config/Schema/sql-changes-1.2.txt
2. If you haven't changed 1.1 version files then you can replace 1.1 version with 1.2 or 2.0 version. See INSTALLATION guide from README file.
3. If you have your own changes in existing changes. Then you should diff both versions with any Diff Softwares for e.g. Kdiff (http://kdiff3.sourceforge.net) Please take a backup of your existing files before overwriting.
4. I suggest you please do not overwrite new plugin to existing plugin instead of this you should make your changes in new plugin.


4. Upgrade from 2.0 to 2.1

1. Run queries from yourapp/app/Plugin/Usermgmt/Config/Schema/sql-changes-2.1.txt
2. If you haven't changed 2.0 version files then you can replace 2.0 version with 2.1 version. See INSTALLATION guide from README file.
3. If you have your own changes in existing changes. Then you should diff both versions with any Diff Softwares for e.g. Kdiff (http://kdiff3.sourceforge.net) Please take a backup of your existing files before overwriting.
4. I suggest you please do not overwrite new plugin to existing plugin instead of this you should make your changes in new plugin.